It is currently Tue Sep 23, 2014 2:21 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 13 posts ] 
Author Message
 Post subject: Horn keeps blowing fuses
PostPosted: Tue Feb 15, 2011 11:14 am 
Offline
Posts like an LN3
Posts like an LN3
User avatar

Joined: Sun Mar 08, 2009 11:30 pm
Posts: 459
Location: Hillsdale, Michigan
Year and Trim: 97 Pontiac GP GT
So this just started recently. I tried to honk my horn at some stupid drunks that darted out in front of my car. Well it sounded funny so I tried it again and it didn't work at all. So the next day, I took a look at it and found that the fuse for the horn was blown. No problem, get another fuse and install it. Simple as that. Well I replaced the fuse and tried the horn and nothing. Checked fuse again, and it was blown. Replaced it again, and same outcome. Has anyone ever had this happen? I checked the wires for maybe a wire that was grounded out but I didn't see anything. Can anyone help?

_________________
Joe
Image
Rebuilt L36, Silverstar highs/lows and fogs, new brake lines, rotors, calipers, pads, ZZP Exhaust, Projector Headlights, Tinted Tails and Windows.
Mods to come- LED Tails, HID Kit, Top Swap (springtime)


Top
 Profile  
 
PostPosted: Tue Feb 15, 2011 6:49 pm 
Offline
Resident Gearhead
Resident Gearhead
User avatar

Joined: Mon May 19, 2008 10:19 pm
Posts: 5510
Location: Hillsboro, Oregon
Year and Trim: 2000 SSEi
2004 GMC 2500HD
2013 Buick Regal GS
Should be a simple circuit of a relay fuse and switch, you either have a bad horn, wiring or relay.

_________________
95se wrote:
Mini vans suck so bad! I dont own one but i drive the work van at my shop and you instantly drive like a idiot when your in one!


2000 SSEi "The Rubber Chicken" (L32 long block, S1x, Comp Cams 105# springs, OR rods, 3.0 Smoothflow MPS, Pacesetters 1-5/8 primaries, Zillamotorsports P&P SC, JP single roller timing set, FWI, Magnaflow cat, Interceptor scangauge, AEM wideband, Powerslot rotors, Hawk ceramic pads, solid transmission mount, HPT)
Image


Top
 Profile  
 
PostPosted: Tue Feb 15, 2011 8:37 pm 
Offline
Posts like an LN3
Posts like an LN3
User avatar

Joined: Sun Mar 08, 2009 11:30 pm
Posts: 459
Location: Hillsdale, Michigan
Year and Trim: 97 Pontiac GP GT
After work I'm gonna try another horn on it. Going to my brothers who also has a 97 gp gt with a good horn.

_________________
Joe
Image
Rebuilt L36, Silverstar highs/lows and fogs, new brake lines, rotors, calipers, pads, ZZP Exhaust, Projector Headlights, Tinted Tails and Windows.
Mods to come- LED Tails, HID Kit, Top Swap (springtime)


Top
 Profile  
 
PostPosted: Wed Feb 16, 2011 10:23 am 
Offline
Posts like an LN3
Posts like an LN3
User avatar

Joined: Sun Mar 08, 2009 11:30 pm
Posts: 459
Location: Hillsdale, Michigan
Year and Trim: 97 Pontiac GP GT
Well last night I swapped in my brothers horn from his gp and the problem still occured.

_________________
Joe
Image
Rebuilt L36, Silverstar highs/lows and fogs, new brake lines, rotors, calipers, pads, ZZP Exhaust, Projector Headlights, Tinted Tails and Windows.
Mods to come- LED Tails, HID Kit, Top Swap (springtime)


Top
 Profile  
 
PostPosted: Wed Feb 16, 2011 10:49 am 
Offline
Resident Gearhead
Resident Gearhead
User avatar

Joined: Mon May 19, 2008 10:19 pm
Posts: 5510
Location: Hillsboro, Oregon
Year and Trim: 2000 SSEi
2004 GMC 2500HD
2013 Buick Regal GS
Both or just one?

Check the wiring and try swapping the relays. Use a meter and check the resistance through the circuit from the relay to the horns.

Do you have the circuit diagram for them?

_________________
95se wrote:
Mini vans suck so bad! I dont own one but i drive the work van at my shop and you instantly drive like a idiot when your in one!


2000 SSEi "The Rubber Chicken" (L32 long block, S1x, Comp Cams 105# springs, OR rods, 3.0 Smoothflow MPS, Pacesetters 1-5/8 primaries, Zillamotorsports P&P SC, JP single roller timing set, FWI, Magnaflow cat, Interceptor scangauge, AEM wideband, Powerslot rotors, Hawk ceramic pads, solid transmission mount, HPT)
Image


Top
 Profile  
 
PostPosted: Wed Feb 16, 2011 12:33 pm 
Offline
Posts like an LN3
Posts like an LN3
User avatar

Joined: Sun Mar 08, 2009 11:30 pm
Posts: 459
Location: Hillsdale, Michigan
Year and Trim: 97 Pontiac GP GT
No I dont have a diagram. I put my original horn in his car and it worked just fine but nothing in my car. Even swapped our relays and nothing solved it. Will be digging into it more tomorrow on my day off work. It's not a big problem but just kinda bugs me.

_________________
Joe
Image
Rebuilt L36, Silverstar highs/lows and fogs, new brake lines, rotors, calipers, pads, ZZP Exhaust, Projector Headlights, Tinted Tails and Windows.
Mods to come- LED Tails, HID Kit, Top Swap (springtime)


Top
 Profile  
 
PostPosted: Wed Mar 23, 2011 10:08 pm 
Offline
SSEi Member
SSEi Member
User avatar

Joined: Tue Jan 18, 2011 8:44 pm
Posts: 171
Location: Lincoln, NE
Year and Trim: 1998 SE (w/ SLE package)
I never use my horns on my cars to the point that I forget I have horns.

_________________
1992 Chevrolet Lumina base:TOTALED (died at 110k)
1989 Buick Reatta:SOLD (sold at 105k)
1991 Pontiac Bonneville LE:SOLD (sold at 225k)
2001 Cadillac Seville SLS:SOLD (sold at 140k)
1998 Pontiac Bonneville SE:CURRENT (bought w/ 145k)


Top
 Profile  
 
PostPosted: Fri Mar 25, 2011 12:27 am 
Offline
Resident Gearhead
Resident Gearhead
User avatar

Joined: Tue May 20, 2008 4:34 pm
Posts: 3606
Location: Buffalo New York
Year and Trim: 99 SSEi
Pull the relay & see if the fuse blows when you press the button. PM me with an email address if you want a wiring diagram.

_________________
2006 Chevy Monte Carlo SS


Top
 Profile  
 
PostPosted: Sun Mar 27, 2011 6:01 pm 
Offline
Posts like an LN3
Posts like an LN3
User avatar

Joined: Sun Mar 08, 2009 11:30 pm
Posts: 459
Location: Hillsdale, Michigan
Year and Trim: 97 Pontiac GP GT
Well got the horn somewhat working.. it is more of a click coming from both of them. Does that sound like a bad horn or something?

_________________
Joe
Image
Rebuilt L36, Silverstar highs/lows and fogs, new brake lines, rotors, calipers, pads, ZZP Exhaust, Projector Headlights, Tinted Tails and Windows.
Mods to come- LED Tails, HID Kit, Top Swap (springtime)


Top
 Profile  
 
PostPosted: Fri Apr 29, 2011 8:55 am 
Offline
SSEi Member
SSEi Member

Joined: Sat Feb 27, 2010 5:27 pm
Posts: 168
Location: Phila.Pa.
Year and Trim: 2000 ssei
Bonnefied_GM wrote:
I never use my horns on my cars to the point that I forget I have horns.

...and I just about wear mine out from overuse.Mine is not working currently,hoping it is just a bad fuse.

_________________
Black 91 SSE-Where it all started....
Red 95 Grand Prix SE-Gone but not forgotten....
Grey 00 SSEI -The current daily driver.
Dark Grey 2011 Dodge Charger-The new flagship.


Top
 Profile  
 
PostPosted: Sat May 07, 2011 9:11 am 
Offline
Retired Admin
Retired Admin
User avatar

Joined: Sun May 18, 2008 11:07 pm
Posts: 65489
Location: Oregon WCBF'04, '05, '06, '07, '08, '09, '10, '11 Survivor
Year and Trim: .
93 SSEi
95 SLE (SC)
97 Buick LeSabre
Bonnefied and keir, can we keep this on topic? This is about fixing a broken horn, not general discussion on how much you use one.

_________________
Image
Click here for mod list for both cars
93 SSEi, 95 SLE (supercharged) 97 Buick LeSabre Limited
PontiacDad at WCBF '04: Cruise control? That's like surrendering!
Comprehensive guide to troubleshooting, rebuilding, and modifying Eaton Superchargers


Top
 Profile  
 
PostPosted: Sun May 08, 2011 10:47 am 
Offline
Posts like an LN3
Posts like an LN3
User avatar

Joined: Sun Mar 08, 2009 11:30 pm
Posts: 459
Location: Hillsdale, Michigan
Year and Trim: 97 Pontiac GP GT
Here is a video of how my horn sounds now. Both of the horns just have a quick honk and isnt loud like they should be.. I think its something in the car itself, I've tried different horns that I know for a fact are good and the same sound comes from them all.. This is what they sounds like.

Image

_________________
Joe
Image
Rebuilt L36, Silverstar highs/lows and fogs, new brake lines, rotors, calipers, pads, ZZP Exhaust, Projector Headlights, Tinted Tails and Windows.
Mods to come- LED Tails, HID Kit, Top Swap (springtime)


Top
 Profile  
 
PostPosted: Sun May 08, 2011 11:34 am 
Offline
Resident Gearhead
Resident Gearhead
User avatar

Joined: Mon May 19, 2008 10:30 pm
Posts: 8318
Location: Grand Rapids, Michigan
Year and Trim: 2000 Bonneville SSEi
Try applying 12 volts to the green wire right at the horns. If it still has a problem, check for a bad ground.

_________________
Black 2000 SSEi, HIR Headlights, Angel Eyes fogs, 3rd brake light overlay, hi-flo cat, 180 degree thermostat, HS 1.9 rockers, LSx yellow springs, Intense FWI, PCM, shift kit, push rods, and 3.4 Pulley. ZZP Power Log.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group


phpBB SEO